Question DevMenu Crashing

Discussion in 'Switch - Exploits, Custom Firmwares & Soft Mods' started by hamrawk, Jul 12, 2018.

  1. hamrawk
    OP

    hamrawk GBAtemp Regular

    Member
    3
    Oct 18, 2014
    United States
    Has anyone else run into the issue of DevMenu just crashing randomly before having a chance to install an NSP? I was able to install NSPs just fine, played through some of em, loaded more on to install, but then the issues started before I could. It crashes at different points every time which makes me think it's a time trigger, but it also stops dead every time I go to install an NSP - different ones each time. Thoughts?

    I searched the forums and couldn't find anything about it, but if this has already been discussed, feel free to refer me there.
     
  2. castdreams

    castdreams Advanced Member

    Newcomer
    1
    Oct 31, 2016
    United States
    Midwest USA
    Have you attempted to do anything other than installing .NSP files with DevMenu? I've heard that it's very unstable and prone to crashing, but I've never had issues with it myself. Can you try re-downloading/re-installing the title you're using for DevMenu? Maybe also replace the LFS files on your SD card just in case?
     
  3. hamrawk
    OP

    hamrawk GBAtemp Regular

    Member
    3
    Oct 18, 2014
    United States
    Great first suggestions, thank you. I have attempted to do other things in the DevMenu and it seems to just crash randomly as I move around the different menus. The only thing consistent is the crash just before installing an NSP.

    I will try throwing fresh LFS files on the SD -AND- re-downloading PKMNQ and report back.
     
  4. uzi

    uzi Advanced Member

    Newcomer
    2
    Mar 21, 2006
    dont go to firmware / last menu on the there.. shouldnt crash then
     
  5. hamrawk
    OP

    hamrawk GBAtemp Regular

    Member
    3
    Oct 18, 2014
    United States
    No dice. Fresh install of PKMNQ after deleted the game and save data, and copied new LFS files into the card. Same results after putting it all together.

    When setting all this up in the first place, I did read not to go there so I didn't - and still haven't - so I don't think that's it.

    It's starting to get more consistent where it freezes. I can move my cursor around everywhere but as soon as I click Install from SD it freezes. AND I SHOULD MENTION that it does freeze instead of crash. I've been saying it wrong. It does just about the same thing I'd expect if I did go to Firmware, even though I'm not going there.

    Any other ideas?
     
  6. castdreams

    castdreams Advanced Member

    Newcomer
    1
    Oct 31, 2016
    United States
    Midwest USA
    Hmm, I'm fresh out of ideas friend. Just out of curiosity, is Pokemon Quest installed to your SD card or your internal storage? I've got mine installed internally and I've never had it crash on me, but I've only ever used the install .nsp function. Never even clicked on anything else.
     
  7. hamrawk
    OP

    hamrawk GBAtemp Regular

    Member
    3
    Oct 18, 2014
    United States
    Oh good question. It looks like it's installed on the SD card. How... How would I go about moving it to internal memory again...? I know there's a trick to remove the SD card so it forced the game to be installed on system memory, but I'd have to do that later after a bit of jig-juggling. In the meantime, is there another trick to moving it?
     
  8. wolf_

    wolf_ GBAtemp Fan

    Member
    3
    Jan 22, 2012
    United States
    I gad the same problem at first I tried another sd card and it worked so I reformatted the original sd card and copied the files back then it worked
     
  9. hamrawk
    OP

    hamrawk GBAtemp Regular

    Member
    3
    Oct 18, 2014
    United States
    So I'm trying to do the no-SD trick to install PKMNQ back into internal memory, but that failed. I'm now banned from eShop so I can't get that back. I hope TX comes out with their solution soon. :P

    I was afraid someone was going to suggest this... There's so much on the card it becomes a pain to have to do this as a fix but if I get another shot at trying this fix, I'll definitely give it a go. Guess now that eShop isn't working my shot's blown.

    Thank you all for your help! If anyone comes up with any other suggestions or fixes feel free to post. For now I'll just be playing the waiting game.
     
    Last edited by hamrawk, Jul 13, 2018 at 4:10 AM
  10. isoisoiso

    isoisoiso Member

    Newcomer
    1
    Jun 16, 2018
    Argentina
    It crashes when you highlight the "firmware" section
    Would be cool if someone removes that
     
  11. hamrawk
    OP

    hamrawk GBAtemp Regular

    Member
    3
    Oct 18, 2014
    United States
    Anyway, for those that are running into the same issue, just know that I eventually got everything to work. If any of the other suggestions don't work, check to make sure it's not a problem with a particular NSP file. Even though I would start with other NSPs, just having Perception on my SD card at all was causing DevMenu to crash. Deleting Perception.nsp let me install all 5 other NSPs like there was no problem to begin with. I'm not saying stay away from that game, I promise. I'm pretty sure I just had a dud copy.
     
    isoisoiso likes this.
  12. milomc123

    milomc123 Member

    Newcomer
    1
    Jun 26, 2018
    Ireland
  13. hashcheck1

    hashcheck1 GBAtemp Fan

    Member
    3
    Aug 5, 2013
    Delete game save for Pokémon and reinstall game. Will work after that


    Sent from my iPhone using Tapatalk
     
  14. Draxzelex

    Draxzelex GBAtemp Psycho!

    Member
    11
    Aug 6, 2017
    United States
    New York City
    Actually, there's a more official way to do that without using eXhop. Just buy/download whatever you want from the Nintendo website using your Nintendo Account and then update Download Progress from your Switch console under the user with that linked Nintendo Account. Another user has reported this method works despite being banned.
     
  15. milomc123

    milomc123 Member

    Newcomer
    1
    Jun 26, 2018
    Ireland
    ah okay
     
  16. hamrawk
    OP

    hamrawk GBAtemp Regular

    Member
    3
    Oct 18, 2014
    United States
    Can confirm these are what worked for me when I mentioned I was able to install NSPs again:

     
  17. milomc123

    milomc123 Member

    Newcomer
    1
    Jun 26, 2018
    Ireland
    Happy you got it working!
     
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice