COMPLETED Fusee-LEDE Dongle (6$ payload injector)

Discussion in 'Switch - Exploits, Custom Firmwares & Soft Mods' started by capitaineflam25, Jun 24, 2018.

  1. Ita54_2

    Ita54_2 Newbie

    Newcomer
    1
    Jul 4, 2018
    Germany
    Hi where have you buyed this OTG?
     
  2. Localhorst86

    Localhorst86 GBAtemp Maniac

    Member
    7
    Jul 17, 2014
    Germany
    Nintendo works for my dad
    From aliexpress: http://www.aliexpress.com/item/Pra...sk-OTG-Converter-Adapter-For/32849739833.html
    You might find cheaper ones as well, that's the exact one I bought.
    The adapter sits in somewhat loosely so when I unplug it from the switch it stays in the console and I have to pull it out separately. I am thinking about fixing it in place with solder or some glue, but that would prevent me from easily changing the payload.
     
    Last edited by Localhorst86, Jul 9, 2018
    Ita54_2 likes this.
  3. Localhorst86

    Localhorst86 GBAtemp Maniac

    Member
    7
    Jul 17, 2014
    Germany
    Nintendo works for my dad
    Double post. Ignore
     
    Last edited by Localhorst86, Jul 9, 2018
  4. FGFlann

    FGFlann GBAtemp Regular

    Member
    2
    Nov 10, 2015
    After further inspection there is a DHCP server built in but it requires configuring. I'll configure it so wireless functions are always available without ethernet and include it in the next release.
     
  5. 9thSage

    9thSage GBAtemp Fan

    Member
    4
    Aug 8, 2008
    United States
    I got some of these too and I'm not sure how you got them to work. I can't seem to get them to work with this because of how loose they are (which is because of how the usb plug on the dongle sits, not the adapter itself to be clear).
     
  6. weatMod

    weatMod GBAtemp Addict

    Member
    7
    Aug 24, 2013
    United States
    yeah i just flashed a D1 mini with the new external HDD payload
    now if i could just fit it into an old magic gate PS2 memory card with a lipo and charge circuit
    if only i could do tiny soldering i would take the ESP board off of the D1 mini CHG breakout board
    and solder to it directly and add some header pins when the the magic gates memory card pins were for connecting it to a USB to serial FTDI breakout for flashing ,a tiny switch, and a JST connector for plugging in to charge the lipo
     
    DayVeeBoi likes this.
  7. DayVeeBoi

    DayVeeBoi GBAtemp Fan

    Member
    3
    GBAtemp Patron
    DayVeeBoi is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    Aug 17, 2015
    Canada
    Ontario
    skip the lipo & charge circuit and just find the smallest button cell holder you can find. I haven't opened mine up but I am willing to bet with some poking around you could use 3.7 v lithium button cell. Memory card shell would be a nice touch. I think someone put something similar in a replica mario coin of some sort on here last week.
     
    weatMod likes this.
  8. Localhorst86

    Localhorst86 GBAtemp Maniac

    Member
    7
    Jul 17, 2014
    Germany
    Nintendo works for my dad
    I just put it in and it works. But come to think of it, I can see how some adapters might not work because they are too loose.
    After all, they are designed to be plugged into the front of a male usb plug and the router has a female USB port.

    Gesendet von meinem Mi A1 mit Tapatalk
     
  9. 9thSage

    9thSage GBAtemp Fan

    Member
    4
    Aug 8, 2008
    United States
    Yeah. I'm just going to get a short cable to plug the adapter into...I imagine that will do just fine. Maybe not as elegant, but it's not worth worrying about it.
     
  10. Localhorst86

    Localhorst86 GBAtemp Maniac

    Member
    7
    Jul 17, 2014
    Germany
    Nintendo works for my dad
    Hm... thinking about it, a running DHCP Server would probably interfere with the ethernet connection of the device, i.e. you could no longer simply plug it into a wired connection and telnet/ssh in. Unless the DHCP server can be configured to only run on the WiFi interface.
     
  11. weatMod

    weatMod GBAtemp Addict

    Member
    7
    Aug 24, 2013
    United States
    yea because i think i only need to power it for like a minute anyways right , just long enough to log in and deliver the payload
    i think the micro USB will also need to be removed to make it fit ,not sure what pins i will need for flashing this if i remove the micro USB
    i am guessing 3.3v , gnd, rx and tx not sure if i need rst and anything else
    i have flashed some esp8266 based wifi controllers before using a TTL USB to serial FTDI breakout and i only needed RX,TX ,GND and 3.3v , my FTDI has the switch for 5v or 3.3v logic, think i only need a 4 wire header with those pins
    i will just put the pin header and switch where the pins for the magic gate are supposed to go
     
    Last edited by weatMod, Jul 10, 2018
    DayVeeBoi likes this.
  12. Wierd_w

    Wierd_w GBAtemp Regular

    Member
    3
    May 12, 2018
    United States
    OpenWRT/LEDE uses the typical /etc/config/network methodology. This defines each interface independently. As such, the wired interface can be explicitly set at a fixed IP, and the wifi can either be configured to grab a DHCP address from an access point, or to provide DHCP addresses in access point mode, and the two will not interfere with each other. It's just a few bytes of config file away.

    The wireless device is further controlled with /etc/config/wireless, and DHCP rules are defined in /etc/config/dhcp.

    By default, LEDE/OpenWRT disables the wireless interface for security reasons. It is fairly painless to turn back on, and should be possible to alter in the build process's root tree structure in the /target folder of the source package. As such, it should be possible to build a flashable image with the appropriate changes already baked in at basically 0 additional cost.
     
    Last edited by Wierd_w, Jul 10, 2018
  13. MYFW

    MYFW GBAtemp Regular

    Member
    2
    Apr 1, 2014
    Anyone have a router with battery alimentation alternative? Thanks
     
  14. Ita54_2

    Ita54_2 Newbie

    Newcomer
    1
    Jul 4, 2018
    Germany
    Search in aliexpress "Hame"
    Select the second and search down, you find One for 12,68
     
    Last edited by Ita54_2, Jul 10, 2018
  15. Localhorst86

    Localhorst86 GBAtemp Maniac

    Member
    7
    Jul 17, 2014
    Germany
    Nintendo works for my dad
    I see. I was looking into /etc/config/wireless to try to enable the dhcp server. I'll later see what /etc/config/network has to offer :D
     
  16. FGFlann

    FGFlann GBAtemp Regular

    Member
    2
    Nov 10, 2015
    To setup a basic independent wireless network first add to /etc/config/nework

    Code:
    config interface 'wlan'
       option type 'bridge'
       option ifname 'eth0'
       option proto 'static'
       option netmask '255.255.255.0'
       option ipaddr '10.0.0.1'
    Alternatively use whatever IP address you want.

    Then to /etc/config/dhcp:

    Code:
    config dhcp 'wlan'
       option interface 'wlan'
       option start '2'
       option limit '254'
       option leasetime '12h'
       option dhcpv6 'server'
       option ra 'server'
      
    config dhcp 'lan'
       option interface 'lan'
       option ignore '1'
    Then in /etc/config/wireless

    Change option network 'lan' to
    Code:
    option network 'wlan'
    I'm currently tinkering with it to share internet access between both interfaces. I've gotten to the point where I can resolve DNS addresses from the independent network but no actual data transfer as of yet.
     
    Last edited by FGFlann, Jul 10, 2018
  17. Wierd_w

    Wierd_w GBAtemp Regular

    Member
    3
    May 12, 2018
    United States
    You need to define a forwarding rule between the interfaces in /etc/config/firewall

    :P
     
  18. FGFlann

    FGFlann GBAtemp Regular

    Member
    2
    Nov 10, 2015
    Yeah that's what I've been doing to get to the point where I can resolve DNS. I don't know the exact syntax of the rule I need to add to finish it off so I'm reading up on it currently.
     
  19. Wierd_w

    Wierd_w GBAtemp Regular

    Member
    3
    May 12, 2018
    United States
    Check out the recipes page. Very useful.
    http://wiki.openwrt.org/doc/recipes/index
     
    DayVeeBoi likes this.
  20. FGFlann

    FGFlann GBAtemp Regular

    Member
    2
    Nov 10, 2015
    I tried all manner of routing and forwarding all to no avail. Only once I put each interface in the same firewall zone with no forwarding or routing at all did the subnets finally start talking to each other. In any case it's now working. @[email protected];
     
  21. FGFlann

    FGFlann GBAtemp Regular

    Member
    2
    Nov 10, 2015

    Attached Files:

    Ita54_2 likes this.
  22. Ita54_2

    Ita54_2 Newbie

    Newcomer
    1
    Jul 4, 2018
    Germany
    Thanks this is amazing work. I buyed One on aliexpress i hope its work in it. :)
     
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice