[List] Games required Firmware version

Discussion in 'Switch - Exploits, Custom Firmwares & Soft Mods' started by B4rtj4h, Oct 5, 2017.

  1. B4rtj4h
    OP

    B4rtj4h Gaming addict #2 and some

    Member
    5
    Apr 16, 2007
    Netherlands
    Bikini Bottom
    None! Nice to see that you noticed :).
     
    lordelan likes this.
  2. Nah3DS

    Nah3DS Madre de Dios! Es El POLLO DIABLO!!!

    Member
    10
    Feb 9, 2010
    Argentina
    I can confirm these games working on 4.1.0

    - Wonderboy: Dragon's Trap
    - Mega Man: Legacy Collection
     
    B4rtj4h and lordelan like this.
  3. lordelan

    lordelan GBAtemp Addict

    Member
    7
    Jan 4, 2015
    Germany
    Oh even those new games don't require 5.x? Interesting.
     
  4. B4rtj4h
    OP

    B4rtj4h Gaming addict #2 and some

    Member
    5
    Apr 16, 2007
    Netherlands
    Bikini Bottom
    Yeah I am seriously wondering what games are 5+?
     
    lordelan likes this.
  5. lordelan

    lordelan GBAtemp Addict

    Member
    7
    Jan 4, 2015
    Germany
    I'd bet Pokémon and Smash at least.
     
  6. zoogie

    zoogie playing around in the dsiware

    Member
    19
    Nov 30, 2014
    Micronesia, Federated States of
    Sushi Striker is out, anybody know the firmware version?
     
  7. andeers

    andeers Advanced Member

    Newcomer
    2
    Aug 22, 2012
    Cote d'Ivoire
    Somebody knows about which FW version does Fifa 18 - World Cup needs?
     
  8. Tere Valentin

    Tere Valentin GBAtemp Regular

    Member
    2
    Nov 21, 2015
    United States
    Bummer. So it needs 4.0.0? I'm soon gonna be a new switch owner and was hoping I can play odyssey while waiting for the cfw and it's tutorials x.x
     
  9. B4rtj4h
    OP

    B4rtj4h Gaming addict #2 and some

    Member
    5
    Apr 16, 2007
    Netherlands
    Bikini Bottom
    You don't know what firmware is on your Switch. Besides, buy it used and try to go for the 000 cartridge. Then you should be good.
     
  10. Hollow Snow

    Hollow Snow Member

    Newcomer
    1
    Sep 25, 2014
    United States
    I can confirm that the recent Blazblue Cross Tag Battle can work on firmware 4.1 however you can't go online, nor download the free dlc that's currently available for a limited time.
     
    lordelan likes this.
  11. ehnoah

    ehnoah GBAtemp Advanced Fan

    Member
    3
    Oct 9, 2012
    Netherlands
    Mario Kart 8 requires a Firmware Update for me. I am on 3.0 not sure what Firmware is on, how can I check?
     
  12. stüssy

    stüssy Member

    Newcomer
    3
    Oct 9, 2008
    Anyone who knows the FW for Hyrule Warriors?
     
  13. leon315

    leon315 POWERLIFTER

    Member
    5
    Nov 27, 2013
    Italy
    i'm able to play it on my 3.0.1 EU switch
     
    stüssy likes this.
  14. thekarter104

    thekarter104 GBAtemp Advanced Maniac

    Member
    5
    Mar 28, 2013
    United States
    LMAO Nintendo must have something that newer games doesn't even require 5.x. Let alone Hyrule Warriors with 3.0.1 and not even 4.x :O
     
  15. Karcz

    Karcz Newbie

    Newcomer
    1
    Jun 18, 2018
    United States
    Does anyone know what the required firmware for Zelda: BOTW Revision 002 is? I just picked up a copy yesterday and it is asking for an update to play. I am currently on 4.0.1. I would like to know if the update on the cart will take me to 4.1.0 or further than that.
     
  16. pLaYeR^^

    pLaYeR^^ GBAtemp Maniac

    Member
    4
    GBAtemp Patron
    pLaYeR^^ is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    Sep 18, 2014
    Austria
    Austria
     
    Last edited by pLaYeR^^, Jun 18, 2018
  17. B4rtj4h
    OP

    B4rtj4h Gaming addict #2 and some

    Member
    5
    Apr 16, 2007
    Netherlands
    Bikini Bottom
    Please read before asking
     
  18. Attainable

    Attainable Advanced Member

    Newcomer
    3
    Aug 24, 2007
    United States
    Just got my copy of Steamworld Dig 2 Physical, no update on 4.1
     
    lordelan likes this.
  19. B4rtj4h
    OP

    B4rtj4h Gaming addict #2 and some

    Member
    5
    Apr 16, 2007
    Netherlands
    Bikini Bottom
    Thanks added!
     
  20. Azel

    Azel GBAtemp Advanced Fan

    Member
    3
    Dec 16, 2014
    France
    just wanted to give the heads up, Xenoblade 2 runs on my 3.0.1 switch :)
     
    Last edited by Azel, Jun 20, 2018 at 11:29 AM
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice