[List] Games required Firmware version

Discussion in 'Switch - Exploits, Custom Firmwares & Soft Mods' started by B4rtj4h, Oct 5, 2017.

  1. Resaec

    Resaec GBAtemp Regular

    Member
    2
    Dec 19, 2017
    Germany
    It looks like every cartridge contains the required FW as an update.

    All games interacting with an online service require you to update. Look at how nintendo auth's your console to learn why that is the case.
    Regarding day 1 patches that are needed to run the game: they are labeled as such in the list (see Kerby)
     
    B4rtj4h and Chuuij like this.
  2. Dan-the-Rebirth

    Dan-the-Rebirth GBAtemp Fan

    Member
    3
    Jan 5, 2014
    Australia
    so kirby is not playable without an update?
     
  3. lukhart

    lukhart GBAtemp Stand User

    Member
    4
    May 10, 2018
    Brazil
    It's playable on 4.1, but the day one update requires 5.1. You can play it without that update though.
     
  4. Dan-the-Rebirth

    Dan-the-Rebirth GBAtemp Fan

    Member
    3
    Jan 5, 2014
    Australia
    You see and thats my point. I think we need a list that tells us what the updates realy do. I know some games don't work with out one like NBA. But some updates seem to do nothing at all except making it unplayable on lower fw.
     
  5. natinusala

    natinusala Win32 error 31 is not an error

    Member
    8
    Dec 1, 2012
    France
    How about Crash ? Does it require 5.1 ?
     
    bjaxx87 likes this.
  6. Der_Blockbuster

    Der_Blockbuster GBAtemp Fan

    Member
    3
    Mar 2, 2016
    Germany
    @B4rtj4h
    Crash Bandicoot N Sane Trilogy - 4.1.0

    — Posts automatically merged - Please don't double post! —

     
    Isaac_ssbm and natinusala like this.
  7. Attainable

    Attainable Advanced Member

    Newcomer
    3
    Aug 24, 2007
    United States
    Thank god. I've been playing the waiting game on 4.1.0 and have been hoping all of these new titles don't need updates. My copy comes in later today.
     
  8. Der_Blockbuster

    Der_Blockbuster GBAtemp Fan

    Member
    3
    Mar 2, 2016
    Germany
    Dude I feel you so hard...it just felt bad to see my Switch waiting or dieing like that. I wanted to play it so badly but can't with any games...
    You don't know how happy I was when I put the Cartridge in, and it didn't update XD, I kinda felt bad for not being able to wait, but I guess the warmboot isnt worth it, tho now I can endure waiting till summer with my buddy Crash ^_^
     
  9. benson733

    benson733 Advanced Member

    Newcomer
    1
    Mar 7, 2011
    Canada
    Alberta, Canada
    I can also confirm Crash Bandicoot N Sane Trilogy running on my 4.1.0 console. XCI Explorer specifies MasterKey3 (4.0.0-4.1.0).
     
    natinusala likes this.
  10. kingraa777

    kingraa777 boom!

    Member
    4
    Apr 17, 2015
    What is wolfenstien and crash ?
     
  11. Der_Blockbuster

    Der_Blockbuster GBAtemp Fan

    Member
    3
    Mar 2, 2016
    Germany
    Maybe re-do the first grade and start reading.
     
    kingraa777 and Isaac_ssbm like this.
  12. benson733

    benson733 Advanced Member

    Newcomer
    1
    Mar 7, 2011
    Canada
    Alberta, Canada
    I can confirm Wolfenstein II The New Colossus running on my 4.1.0 console. XCI Explorer specifies MasterKey3 (4.0.0-4.1.0).
     
  13. B4rtj4h
    OP

    B4rtj4h Gaming addict #2 and some

    Member
    5
    Apr 16, 2007
    Netherlands
    Bikini Bottom
    Can you back this up? Is it E-shop or cartridge?
     
  14. kingraa777

    kingraa777 boom!

    Member
    4
    Apr 17, 2015
    are you some kind of twat ? Obviously i didnt see it anywere maybe im blind only thing i saw was nswdb what said crash is 4.1.0 but also seen elsewere it say 5.1.0

    — Posts automatically merged - Please don't double post! —

    Edit didnt see that post above mine because i posted on page 20 something when i got bored of going throgh all the pages
     
  15. zoogie

    zoogie playing around in the dsiware

    Member
    19
    Nov 30, 2014
    Micronesia, Federated States of
    ESHOP DOWNLOADS DO NOT HAVE FIRMWARES
    ONLY CARTRIDGES HAVE FIRMWARES


    And why are you asking him to reconfirm?
    If you need "backup" then http://nswdb.com/

    That site is honestly the reference everybody should be using for cart firms instead of the nonsense list in the OP.
     
    TheKerplunk likes this.
  16. InsaneNutter

    InsaneNutter GBAtemp Advanced Fan

    Member
    6
    Dec 26, 2007
    Yorkshire, UK
    Just got my pre-order of Crash Bandicoot N Sane Trilogy today from Amazon UK, it works on 4.1.0 which is a nice surprise. I see this was already confirmed anyway :)

    I might be mistaken however i'm pretty sure this last existed long before that site. Either way it's been a well maintained thread so I don't see choice as a bad thing.
     
  17. Der_Blockbuster

    Der_Blockbuster GBAtemp Fan

    Member
    3
    Mar 2, 2016
    Germany
    No problem :grog:
     
  18. B4rtj4h
    OP

    B4rtj4h Gaming addict #2 and some

    Member
    5
    Apr 16, 2007
    Netherlands
    Bikini Bottom
    Boohoo go cry somewhere else you little baby.

    E-shop downloads are not without firmware. The thing there is that if you download them on day1 they can be played on that firmware.
     
  19. salvatore

    salvatore GBAtemp Regular

    Member
    2
    Nov 7, 2013
    Italy
    hi what game woork on fw 1.0.0?
    thanks
     
  20. yeahOmgWtf

    yeahOmgWtf Newbie

    Newcomer
    1
    May 19, 2018
    Haiti
    I inserted a cartridge that needs an update, and I can choose "Update".
    Will I see info about which version it will install, or will it just start the update straight away?
    Even tho I (probably) found out which version it is, I want to be 100% certain...
     
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice