[List] Games required Firmware version

Discussion in 'Switch - Exploits, Custom Firmwares & Soft Mods' started by B4rtj4h, Oct 5, 2017.

  1. volkanceren

    volkanceren Newbie

    Newcomer
    1
    Jul 3, 2018
    Germany
    Hello everyone this is my first post here inbgbatemp. :hrth:

    Today I ordered new dragon quest builders to update my 3.0.1 fw to 4.1.0. It came with 000 cartridge and booted the game without update.
    One thing that I didn't understand well is on the list we have here DQB is written under fw 4.1.0. For my understanding it was for the 000 cartridges. Am I wrong?
     
    Last edited by volkanceren, Jul 3, 2018
  2. B4rtj4h
    OP

    B4rtj4h Gaming addict #2 and some

    Member
    5
    Apr 16, 2007
    Netherlands
    Bikini Bottom
    Not really. 000 cartridges are the first of their print. Most games that have 000 have the minimal firmware on the cartridge that is needed to play the game. However, when in case of a higher game this makes no sense anymore... so it is better to keep looking at this list.

    But do I understand that there is an error? DQB runs on 3.0.1?
     
  3. volkanceren

    volkanceren Newbie

    Newcomer
    1
    Jul 3, 2018
    Germany
    Yes indeed I have fw 3.0.1 Switch and Dragon Quest Builders 000 cartridge runs without update requirement.
     
  4. B4rtj4h
    OP

    B4rtj4h Gaming addict #2 and some

    Member
    5
    Apr 16, 2007
    Netherlands
    Bikini Bottom
    Ok, I changed the list! Thanx for your contribution :)
     
    volkanceren likes this.
  5. Andalitez

    Andalitez Advanced Member

    Newcomer
    1
    Jul 2, 2018
    France
    Final Space
    Thanks for the list.

    Overcooked is actually a 3.0.1 game. Just Tested it now on my 3.0.1 switch
    Not sure how to DM you, but I have a link for quite a comprehensive list,which im not sure if im allowed to post here or not

    Thanks again
     
  6. Varon12

    Varon12 Advanced Member

    Newcomer
    2
    Sep 21, 2016
    Canada
    Spider Skull Island
    Last edited by Varon12, Jul 4, 2018
  7. Xellos2099

    Xellos2099 GBAtemp Fan

    Member
    3
    Apr 9, 2006
    United States
    i wonder what firmware will octopath travler be
     
  8. B4rtj4h
    OP

    B4rtj4h Gaming addict #2 and some

    Member
    5
    Apr 16, 2007
    Netherlands
    Bikini Bottom
    I think I know what site you mean... thanks for reporting. I changed Overcooked.
     
  9. spindizzy

    spindizzy Newbie

    Newcomer
    1
    Jul 5, 2018
    Germany
    I just bought Super Mario Odyssey on a 002 cartridge and it contained and required 4.1 firmware (my switch was on 4.0.1 before).
     
    Last edited by spindizzy, Jul 6, 2018
  10. Dodain47

    Dodain47 GBAtemp Maniac

    Member
    7
    Jan 1, 2017
    Austria
    Likely 5.1.0. The latest Firmware had been released on May 31. 2018.
     
  11. PitPitPit

    PitPitPit GBAtemp Regular

    Member
    1
    Jan 18, 2017
    Gambia, The
    Say i'm on FW 3.0.0 and wanna play Mario Odyssey. The list says the game requires 3.0.1 and i suppose that FW-update is included on the cartridge. However the list also states that the Day1 Patch needs 4.0.0. Is this patch required to play and if so what would be the best way to get onto FW 4.0.0? Does that mean that i have to buy another cartridge that explicitly comes with the 4.0.0 update? Or would Nintendo push the latest FW onto my system anyway as soon as i try to download the Day1 patch?
     
  12. B4rtj4h
    OP

    B4rtj4h Gaming addict #2 and some

    Member
    5
    Apr 16, 2007
    Netherlands
    Bikini Bottom
    No it is not required to play. However not all functions do work.
     
    PitPitPit likes this.
  13. aos10

    aos10 ❤ Zelda ❤\(^o^)/

    Member
    8
    Apr 10, 2012
    Saudi Arabia
    is there any news about the ability to edit the ROM so you can play it on low frameware?
     
  14. B4rtj4h
    OP

    B4rtj4h Gaming addict #2 and some

    Member
    5
    Apr 16, 2007
    Netherlands
    Bikini Bottom
    Yes, you can’t. The firmware has different memory allocations. So games will crash or have bugs. I believe on reddit someone tried that with Zelda BOTW
     
  15. binarymelon

    binarymelon Member

    Newcomer
    1
    Sep 6, 2017
    Canada
    Wouldn't the required firmware probably be based on what was the latest when the game went gold? This could conceivably be prior to the latest update couldn't it?
     
  16. Dodain47

    Dodain47 GBAtemp Maniac

    Member
    7
    Jan 1, 2017
    Austria
    Yes, it all depends on when the game got complet and entered mass production.
     
  17. lukhart

    lukhart GBAtemp Stand User

    Member
    4
    May 10, 2018
    Brazil
    It's confirmed that Octopath Traveller is a 5.0 game from the leaked release today.

    Proof (look for master key revision):
    unknown.png
     
    Last edited by lukhart, Jul 11, 2018
  18. B4rtj4h
    OP

    B4rtj4h Gaming addict #2 and some

    Member
    5
    Apr 16, 2007
    Netherlands
    Bikini Bottom
    That would mean that the firmware could also just be a version number and not add anything significant.
     
  19. baldman

    baldman Newbie

    Newcomer
    1
    Apr 8, 2017
    Moto GP 18 requires firmware over 5.x.x because my .XCI backup doesn't work on my 4.1.0 SX OS.

    You also can check it on NSWDB.com

    Regards
     
    Last edited by baldman, Jul 11, 2018
  20. comput3rus3r

    comput3rus3r GBAtemp Advanced Maniac

    Member
    9
    Aug 20, 2016
    United States
    what firmware is lego incredibles? it's not working on my 4.1 switch.
    nevermind nswdb.com tells you the firmware version.
     
    Last edited by comput3rus3r, Jul 11, 2018
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice