RELEASE Newest Hekate SDfiles.zip

Discussion in 'Switch - Exploits, Custom Firmwares & Soft Mods' started by tomGER, Jun 4, 2018.

  1. tomGER
    OP

    tomGER GBAtemp Regular

    Member
    4
    Feb 6, 2017
    Germany
    Try updating manually again, there was a hotifx for v5.1
     
  2. Memoir

    Memoir Just a Memory

    Member
    18
    GBAtemp Patron
    Memoir is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    Jun 24, 2007
    United States
    Somewhere, over there!
    Should do 5.1.1 cuz hotfix. :P
     
    tomGER likes this.
  3. tomGER
    OP

    tomGER GBAtemp Regular

    Member
    4
    Feb 6, 2017
    Germany
    I should probably start doing that, yeah ;P
     
    morrison22 and Memoir like this.
  4. Memoir

    Memoir Just a Memory

    Member
    18
    GBAtemp Patron
    Memoir is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    Jun 24, 2007
    United States
    Somewhere, over there!
    Would allow the updater to be more efficient. ;O
     
  5. Davelo

    Davelo Member

    Newcomer
    1
    Feb 10, 2018
    Bahrain
    after updating to v5.1 i can't launch homebrew it just crashes my switch
     
  6. jakibaki

    jakibaki GBAtemp Regular

    Member
    5
    Mar 3, 2017
    Germany
    Were you by any chance using an ftpd-profile and updated through the sdfileupdater because I suspect that might be causing issues :/

    — Posts automatically merged - Please don't double post! —

    Could you please upload the content of sd:/logs/ftpd.log?
     
  7. Davelo

    Davelo Member

    Newcomer
    1
    Feb 10, 2018
    Bahrain
    Yes i updated through sdupdater but I don’t know what do you mean by ftpd-profile and after crashing i updated manually and same problem
     
  8. jakibaki

    jakibaki GBAtemp Regular

    Member
    5
    Mar 3, 2017
    Germany
    Oh, alright then it's not what I suspected. Thanks for the help!

    Can't help you with your issue though :/ Worst case you could just reformat your sdcard but that doesn't seem like a good solution.
     
  9. stingray1059

    stingray1059 GBAtemp Regular

    Member
    2
    Feb 7, 2009
    yes im on exfat. how to fix this??
     
  10. Scrlklk

    Scrlklk Member

    Newcomer
    1
    Jul 30, 2017
    Japan
    it does support 4.1 right? I keep getting 2162-0002 crashing error when I try to boot from hekate into cfw

    edit: turns out it was because i didnt have exfat support on the ofw, fixed by following this guide
     
    Last edited by Scrlklk, Jul 8, 2018
  11. OperationNT

    OperationNT GBAtemp Regular

    Member
    3
    May 1, 2016
    France
    Unfortunatly, I still get the issue with the latest version (I think it's a bug in "sys-ftpd.kip" and your latest version did not changed this module). I also compiled "sys-ftpd.kip" myself from the latest code version and I get the same issue.
     
  12. Twistedziefer

    Twistedziefer GBAtemp Regular

    Member
    2
    May 18, 2018
    United States
    Los Angeles
    Reformat to fat32. Exfat is know to cause file corruptions.
     
  13. jakibaki

    jakibaki GBAtemp Regular

    Member
    5
    Mar 3, 2017
    Germany
    What firmware are you on? I developed the sysmodule on 5.1 (since that's the only switch I have) so there might be incompatibilities with older firmwares :(
     
  14. OperationNT

    OperationNT GBAtemp Regular

    Member
    3
    May 1, 2016
    France
    I am on FW 4.0.1 and my SD card is formatted in exFAT. Is there any log I could activate to find the issue?
     
    Last edited by OperationNT, Jul 8, 2018
  15. Favna

    Favna #PCMasterRace

    Member
    5
    Sep 12, 2009
    Netherlands
    So I fell victim to the Sys-FTPD corruption through SDFilesUpdater when going from 5.1 to 5.2 through the tool and well I didn't skim this thread or the changelog beforehand so I never saw the warnings about the SD file corruption (assuming it wasn't there on 5.1 already, if it was I just didn't read it)

    And the problems started... in Hyrule Warriors (I didn't try anything else yet) the game "saves" but then I close out and exit, go right back in my saved data is gone and I'm back to the state I had before doing whatever I did (i.e. level a character, it goes back to whatever lower level it had before)

    Oh boy so ominous! Surely I'm going to ask, what to do right? Well thank god I won't have to pester you with that. No I managed to get out of the loop and I'd just like to report status just in case anyone else falls into the same hole.

    I've tried in this order:
    • Backing up all files then reformatting the SD card (deleted partitions with EaseUS Partition Manager then created a new ExFAT permission with windows formatter) and putting the files back but that is to no avail.
    • Run the fixer from the hekate payload ("all sd files" version) (returned "total archive bits cleared: 934) but to no avail
    • telling the system to remove the game data and getting it back afterwards - this was useless coz it is a cartridge game so it only had to re-download the update
    • Injecting an older save file from before this whole charade started. Wooh this worked!!

    TL;DR: BACKUP, BACKUP, BACKUP. I was gods holy lucky enough that I shared some save files in another thread otherwise I'd be seriously screwed over too.




    I use Hekate v3.2 with a 3D printed RCM JoyCon Jig and lause f-g through Windows Powershell
     
  16. Memoir

    Memoir Just a Memory

    Member
    18
    GBAtemp Patron
    Memoir is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    Jun 24, 2007
    United States
    Somewhere, over there!
    Corruption through FTP? What?
     
  17. CuriousTommy

    CuriousTommy GBAtemp Fan

    Member
    3
    Jul 22, 2014
    United States
    I am having trouble launching the FTP module on my switch. I always get the error code 2002-6605 after the switch logo appears. It doesn't matter if I select FTP with CFW or LayerFS. My switch is on 3.0.0
     
  18. stingray1059

    stingray1059 GBAtemp Regular

    Member
    2
    Feb 7, 2009
    after updating to 5.1 homebrew does not load.. i reformatted back to fat32.. still doesnt load.. i can use layeredfs but when i go to album homebrew doesnot launch.. please help.
     
  19. stingray1059

    stingray1059 GBAtemp Regular

    Member
    2
    Feb 7, 2009
    homebrew laucher dont boot when pressing album... please help.. im using latest hekate and sdfiles v5
     
  20. sirAnger

    sirAnger GBAtemp Fan

    Member
    3
    Dec 4, 2002
    United States
    Michigan
    When you press the album icon, does it go into the album, or are you getting an error message?
     
    tomGER likes this.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice