Switch Hacking & Homebrew Discussion

Discussion in 'Switch - Emulation, Homebrew & Software Projects' started by EpicLPer, Mar 12, 2017.

  1. SpanishGamer911

    SpanishGamer911 Advanced Member

    Newcomer
    1
    Dec 20, 2017
    United States
    Bronx, NY
    So say CFW is a thing soon for all current firmwares on the switch.
    Will be be able to play backups/dumps right away or no?
     
  2. HexZyle

    HexZyle Pretty Petty Pedant

    Member
    3
    Sep 12, 2015
    Australia
    Someone has to be working on it. Backups don't create, decrypt, install and sign themselves. If no-one works on it, it won't get made.
     
  3. Ghost92

    Ghost92 GBAtemp Regular

    Member
    2
    Jun 29, 2017
    Colombia
    I asked a question before, and you will not find it because they have blocked it. Although I did it with an image of a shark kindly asking that the Exploits be released as promised.

    5LuKcUka3hs.jpg


    Then they called me incompetent because I am the reason why developers hate GbaTemp haha

    The truth is I want to hack my 4.1.0, it's time! : D
     
    Last edited by Ghost92, Mar 14, 2018
    TotalInsanity4 and Y0sh1 like this.
  4. team-knight-rider

    team-knight-rider Member

    Newcomer
    1
    Dec 29, 2017
    Philippines
    Hi,
    My friend is selling his Switch with ver 2.0.1, it is good to buy or need ver 3.0?
    thanks
     
  5. HexZyle

    HexZyle Pretty Petty Pedant

    Member
    3
    Sep 12, 2015
    Australia
    Either is good. To update to 3.0 though you need a cartridge version of Pokken Tournament
     
  6. SpanishGamer911

    SpanishGamer911 Advanced Member

    Newcomer
    1
    Dec 20, 2017
    United States
    Bronx, NY
    I was given a code for Bayonetta. I redeemed it but i realized that when going to download it. I won't let me cause i need to update, so i'm guessing i'm pretty much screwed at this point.

    Is there any work around at the moment tho?

    EDIT: Nevermind, i updated anyway F*** it i'm not to worried anymore about CFW/HB right now till everything is more developed like the 3DS. Which i know will take years probably & That's fine, if anything i can just buy another switch.
    Doesn't even cost a lot.
     
    Last edited by SpanishGamer911, Mar 16, 2018
  7. royvedas

    royvedas Member

    Newcomer
    3
    Apr 12, 2007
    It will be interesting to see if anything will ever come of these socalled hacks that are in the works. It has been awfully quiet lately.
     
  8. SpanishGamer911

    SpanishGamer911 Advanced Member

    Newcomer
    1
    Dec 20, 2017
    United States
    Bronx, NY
    They'll happen eventually this stuff isn't easy & doesn't just happen over night.
     
  9. anhminh

    anhminh Pirate since 2010

    Member
    5
    Sep 30, 2010
    Vietnam
    Well, it does for me. Everytime I wake up the hack had already been posted for awhile.

    But seriously, it would be nice to see update one a week though.
     
  10. pokeplayer984

    pokeplayer984 Newbie

    Newcomer
    1
    Mar 19, 2018
    United States
    I actually got a Switch that had Version 3.0.0 off of eBay. Had to pay $399 for the screen alone and got Joy-Cons for it. (The Red & Blue Combo.) I've been busy through the weekend to get emulators on it and am happy to report that I got NES and SNES Emulators working.

    My first time doing it and I'm glad I got to pull it off.

    Oh, now for the main reason I posted. Think we can get an Atari 2600 Emulator working for it? Also, don't post that there's no interest for it. Trust me, there is.
     
    WiiuGold and Ichii Giki like this.
  11. delete12345

    delete12345 GBAtemp Advanced Fan

    Member
    4
    Feb 27, 2010
    United States
    Taipei, Taiwan
    I have dkp-pacman installed, and have installed switch-sdl2_ttf. When making a test app, GCC is complaining that it cannot find TTF_Init() and TTF_Quit(). Does anyone have insights on how to fix this?

    This is my Makefile: http://hastebin.com/uqelamoxas.makefile

    And this is my source code:

    Code:
    #include <SDL.h>
    #include <SDL_ttf.h>
    
    int main(){
        TTF_Init();
        TTF_Quit();
        return 0;
    }
     
  12. Randall Stevens

    Randall Stevens Member

    Member
    4
    Oct 5, 2003
    Hong Kong

    That seems to be the going rate. I'm thinking of selling my 3.0 with joycons as well.
     
    Last edited by Randall Stevens, Apr 4, 2018
  13. aos10

    aos10 Fairy Princess

    Member
    7
    Apr 10, 2012
    Saudi Arabia
    soo, i got a new switch as a gift for my birthday (2 months late) with super Mario odyssey and Zelda
    after i almost cried in front of my friends because of the surprise :cry:, and went back to home, the first thing i did is to check the FW, and it's on 3.0.2
    i read this is compatible with super mario odyssey, but it's bad for homebrew and hacking
    the last public hacking FW is for 3.0.0, right?
    if no, what the avaiable options?

    i don't plan to even connecting to internet right now, zelda and mario will take too much time for me, the only other game i wants right now is Bayonetta 2, which i am afraid is not compatible with 3.0.2.

    the box of the switch is designed for middle east, Red and Blue one.

    can i do the Mario Golf trick on it? is still not connected to internet.
     
  14. Viri

    Viri GBAtemp Advanced Maniac

    Member
    9
    Sep 13, 2009
    United States
    Currently home brew only works on 3.0.0, but you're not missing out on a whole lot, unless you're hell bent on playing emulators with missing features. CFW will work on pretty much everything pre 5.0.0. 5.0.0 and up will require a bit more difficulty.
     
    aos10 likes this.
  15. Schizoanalysis

    Schizoanalysis From somewhere inside the rabbit hole...

    Member
    5
    Jun 23, 2009
    ...
    What firmware does a new out of the box Switch generally come with? Is it hackable?

    Thanking you kindly!
     
  16. zoogie

    zoogie playing around in the dsiware

    Member
    19
    Nov 30, 2014
    Micronesia, Federated States of
    1. About 4.x-ish (need 3.0.0 for it to be immediately hackable -- non-piracy)
    2. By this summer most likely (bootromhax).

    Long time no see, heh. Always liked your avatar.
     
    Last edited by zoogie, Apr 6, 2018
    Schizoanalysis likes this.
  17. Schizoanalysis

    Schizoanalysis From somewhere inside the rabbit hole...

    Member
    5
    Jun 23, 2009
    ...

    Talk about good taste!

    Thank you you the reply.
     
    zoogie likes this.
  18. Fer_Elizalde

    Fer_Elizalde Member

    Newcomer
    1
    Jan 15, 2018
    Mexico
    What do you think about hacking a 5.0.1 console, some say it will be less convenient, but I wonder how it would be less convenient. Any thoughts?
     
  19. TotalInsanity4

    TotalInsanity4 GBAtemp Supreme Overlord

    Member
    18
    Dec 1, 2014
    United States
    Under a rock
    All we know is that we'll need to jump through more hoops somehow. It might involve a hardmod, or it might be a softmod that only works a small percentage of the time, for instance
     
  20. Fer_Elizalde

    Fer_Elizalde Member

    Newcomer
    1
    Jan 15, 2018
    Mexico
    That's what I was thnking, maybe narrowing down our options to only hardmod or something like that. Hope its not so difficult, because I already updated to 5.0.1 I wanted to buy some games so bad.
     
    TotalInsanity4 likes this.
Loading...
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice