Update 11.7 and Homebrew

Discussion in '3DS - Homebrew Development and Emulators' started by GalladeGuy, Jun 19, 2018.

  1. NightShadow8599

    NightShadow8599 Newbie

    Newcomer
    1
    Jun 19, 2018
    United States
    Hell


    I'm getting a flashcart here soon but I want to get into home brew. The hax i am using are rpg and basehaxx.
     
    TurdPooCharger likes this.
  2. TurdPooCharger

    TurdPooCharger Eat your vegetables.

    Member
    4
    Jan 1, 2018
    United States
    @NightShadow8599, you hit the jacked pot (keyword, jacked not jack). Give this man some likes for his discovery.

    Calling @GalladeGuy , think we got our first two confirmed haxes that didn't make it this round.
     
  3. GalladeGuy
    OP

    GalladeGuy Freeze Kirby :3

    Member
    10
    Oct 28, 2015
    United States
    I'm going to wait for confirmation from more people before adding it. If they are really patched, it's just a case of them needing to be updated.
     
  4. NightShadow8599

    NightShadow8599 Newbie

    Newcomer
    1
    Jun 19, 2018
    United States
    Hell


    Thanks for letting me know that they may not work. I'll just wait for my flashcart
     
  5. Kwyjor

    Kwyjor Member

    Newcomer
    1
    May 23, 2018
    Canada
    Wasn't basehaxx already dead under 11.6, as per http://3dbrew.org/wiki/Homebrew_Exploits ?

    I would have thought RPwnG was dead as well, but I guess people must still have the old installation kicking around.
     
  6. nl255

    nl255 GBAtemp Addict

    Member
    6
    Apr 9, 2004
    Actually there are several ways they could do it. The only real way, and keep in mind this is both theoretical and would be extremely risky, is to update the MCU firmware so that on boot the MCU injects extra verification/security code into the boot process via DMA or a similar mechanism.

    Other than that they could heavily encrypt/obfuscate the areas of memory that CFW patches which would result in any 3ds with CFW being unusable for anywhere from a few weeks to a few months depending on how complex it is to reverse engineer. Or they could simply delete or rename any .firm file found on the NAND and/or the root of the SD card which would stop b9s from working though that could be fixed by switching to fastboot3ds.
     
    lone_wolf323 likes this.
  7. NightShadow8599

    NightShadow8599 Newbie

    Newcomer
    1
    Jun 19, 2018
    United States
    Hell

    Basehaxx and rpg hax wasn't patched last update or 11.6. They may be patched on this update or 11.7
     
  8. KuroTheBang

    KuroTheBang Advanced Member

    Newcomer
    2
    Nov 29, 2014
    Gambia, The
    I am using B9S with Luma. Can I update without problems ?


    Sent from my iPhone using Tapatalk Pro
     
  9. NightShadow8599

    NightShadow8599 Newbie

    Newcomer
    1
    Jun 19, 2018
    United States
    Hell


    I'm sure you can if you have gm9 backup you system.
     
  10. TurdPooCharger

    TurdPooCharger Eat your vegetables.

    Member
    4
    Jan 1, 2018
    United States
    Warning: Spoilers inside!

    Edit - Sorry guys, I meant to post at this thread: http://taraftartekstil.com/threads/can-internal-storage-go-bad.507908/#post-8084661
    Please ignore and mods delete this.
     
    Last edited by TurdPooCharger, Jun 23, 2018
  11. Bondgirl85

    Bondgirl85 Advanced Member

    Newcomer
    1
    Apr 12, 2018
    United States

    Updated and everything still works, freeshop, Luma, FBI, Checkpoint, Anemone.
     
  12. Lokohein321

    Lokohein321 Newbie

    Newcomer
    1
    Jun 25, 2018
    Brazil
    People, im using safehax+soundhax in 11.4 still, it still works or if update i lose It?
     
  13. mehmeh11

    mehmeh11 GBAtemp Regular

    Member
    1
    Jul 14, 2016
    Peru
    I have luma (I think 9.1) and sighax, is it safe to update?
     
  14. AlexanderLS

    AlexanderLS GBAtemp Regular

    Member
    2
    Oct 7, 2016
    United States
    Soundhax hasn't worked for awhile.
    You can use your soundhax to get a proper b9s install before you update.
    http://3ds.hacks.guide/
     
    Last edited by AlexanderLS, Jun 26, 2018
  15. VzUh

    VzUh you are now reading my custom title

    Member
    2
    Feb 5, 2017
    Spain
    inside me
    afaik latest luma is 9.0, but anyway, if you have luma and sighax/boot9strap it's safe to update
     
  16. Sponsie1000

    Sponsie1000 Newbie

    Newcomer
    1
    Jun 28, 2018
    Netherlands
    I use rpg hax for homebrew and I can't access it anymore after updating either... So that might be a thing now. Also i'm quite new to this, are there any known ways/steps I can undertake to get it working again?
     
    Last edited by Sponsie1000, Jun 28, 2018
  17. Kwyjor

    Kwyjor Member

    Newcomer
    1
    May 23, 2018
    Canada
    If you want to access the Homebrew Launcher, you'll need Steelminer. You could use oot3dhax if you have a Powersave, but it seems new Powersaves for 11.7 haven't been made yet. Alternatively, if you have access to another 3ds still capable of launching the Homebrew Launcher, you can use that to install oot3dhax or stickerhax to an Ocarina of Time or Sticker Star cart (with a payload appropriate for your system.)

    Or you can just forget about *hax completely, buy Sudoku for $2 from the eShop, and use Seedminer to install cfw.
     
  18. kathy

    kathy Member

    Newcomer
    2
    Mar 12, 2012
    United States
    Sorry, but I'm kinda dumb. I installed Luma and use it to play backups and homebrew. Updating won't affect that usability, right?
     
  19. Sponsie1000

    Sponsie1000 Newbie

    Newcomer
    1
    Jun 28, 2018
    Netherlands
    Okay, but l will need a friend/online-person-with-homebrew for Steelminer to work right? l really liked RPwnG for the fact that you didn't need anything else besides the free part of the game and some online files :/
     
    Last edited by Sponsie1000, Jun 28, 2018
  20. Kwyjor

    Kwyjor Member

    Newcomer
    1
    May 23, 2018
    Canada
    Just follow the instructions at http://steelminer.jisagi.net/ .

    I might add that if you have access to an ntrboot cart, you can launch godmode9 without making any persistent changes to your 3ds beyond copying a couple of files to your SD card. Godmode9 will automatically create essential.exefs (which includes movable.sed) the first time it runs. The R4i Gold 3DS Plus is reasonably cheap at nds-card.com , will let you run Nintendo DS ROMs on your 3ds, and will be handy if you ever change your mind about installing cfw.

    If http://3dbrew.org/wiki/Homebrew_Exploits is accurate, it was quickly squashed.
     
    Last edited by Kwyjor, Jun 29, 2018
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice